From Lundman Wiki
Jump to: navigation, search

I'm basically at the same spot you are. I've been able to get the 110 fw on the 100, but cannot use HDMI. I've switched to component, so everything basically works like normal.

I've tried comparing the firmware between 100 and 110 to see if I can find where it would enable me to select analog for DTS, but no luck thus far.


Yeah.. I'm reasonably sure it isn't anything in the binaries mono and gaya, they differ only by 4 bytes or something equally small. It is by far likely to be in libsample, or other libraries in /usr/lib/. However I did notice the kernel module is tried to the ucode and needs to match. More importantly, I've not been able to successfully unload it and load again. So most likely the ucodes and kernel modules need to be moved, then figure out what part of gaya detects if the option should be enabled.

But really we should ignore gaya, get the "mono" arguments it uses to play DTS->2ch, and work with that until it works. But there is a high chance those ucodes will just not work right with HDMI-1.1. I also doubt there will be a model with HDMI1.1 *and* DTS decoding.

Perhaps just buy a B-110, put it in the A-100 case :)

I'm more interested in if the CSS_ucode could be loaded.

-- lundman

Yeah, unfortunately I don't have too much time to tinker with it. Especially since it wouldn't give me too much advantage, since everything I'd like to have is working via component. Perhaps in the next month or two I'll get a little more time to play around, but at this point there are just too many other things going on.

-- bstock

Hi guys. I am not so keen on coding and linux as you but have tried few things. I could make the Gaya interface allow option PCM for DTS (edited /opt/sybhttpd/default/display.html and /opt/sybhttpd/default/setups.cgi), but unfortunately save does not work - cannot complete operation. This makes sense to me now after I read more. Do you believe there will be any chance to add DTS support to A100 some day? I bought it just before they released A110 and does not make sense to chnage it... Other thing I did is change manually audio_dts=raw to audio_dts=pcm in /tmp/settings. The effect is that when I played DTS mkv the video stuttered so this had some effect (some additional processing of DTS by chip maybe) - unfortunately no sound output:( Probably some module or else is missing... Let me know if I can help with something. Unfortunately I am using HDMI to connect to my TV but just in case - can you let me know how to make an A-110 firmware be A-100 firmware? Thanks in advance.


Hi! I'm not really sure, but could we use libdca to enable DTS support in NMT? I also have a NMT, which has HDMI 1.3 so I could try to use PCH A-110 firmware, but I need some help with it! :)

-- vlx

Problem is the ucodes/xor are signed with RSA and we don't have the keys. So it is ALL ucodes when you want to play. So when we move audio_ucode over, it has to be with video. And the only DTS ucode we have come with HDMI1.3 video ucode. So, A-100 will fail on HDMI as it is HDMI-1.1 only. If they were to release a HDMI-1.1 player with DTS, we'd be set.

Any other NMT with HDMI1.3 and without DTS could most likely be hacked into a A-110 player.

-- lundman

I see. Could you move audio_ucode over to a device, which has HDMI1.3? I ended up in hacking my device to a PCH A-110 firmware. DTS is just so sweet! :) When a better solution comes up I can revert it back. Until then I'll stick with this.


Did you have to change the A-110 firmware to look-a-like A-100 firmware? Because I didn't. Maybe we made something different? Or it is just that A-100 is older hardware than new non PCH NMT's with HDMI1.3

-- vlx

It would be my guess that A100 h/w is slightly different, or at very least the HDMI-1.3 chip. If you have a HDMI-1.3 unit, then making it be a A110 with DTS should be no problem at all.

-- lundman

Does the firmware release for EGreat 31A and 31C (these players are only HDMI 1.1) that contains the DTS downmix change anything?

-- breizh90

They most likely do yes, I have not had the time to try. Someone should re-sign a EGreat firmware as POP401 and see if it works. (But realise, you might brick it, etc)

-- lundman